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FileMaker 13 Specific features

FileMaker Pro and FileMaker Pro Advanced Specific Features for the Middle East and India

FileMaker Pro 13 and FileMaker Pro 13 Advanced is an enhanced version of the #1-selling easy-to-use
database software, adapted for the Middle East and India.

Use this guide to explore and understand the specific features of FileMaker for the Middle East and

India:
Contents
2 Support of Middle Eastern and Indian languages
Paragraph direction
Character Direction
Digits
7 Spelling Option
7 Layout of Middle Eastern Content
Controls
Mirror Layout
13 Sorting - Search/Find
16 FileMaker WebDirect
18 Diacritics and Ligatures
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FileMaker 13 Specific features Localized User Interface

Support of Middle Eastern and Indian languages

FileMaker Pro and FileMaker Pro Advanced provide enhanced support of Arabic & Hebrew as well as
Indic languages for Windows and Macintosh.

FileMaker Pro and FileMaker Pro Advanced come with enhanced options for entering and displaying
Middle Eastern and Indian texts and special settings for laying out these languages.

The paragraph and character directions are key elements for laying out Arabic or Hebrew texts.

Paragraph direction

It is important to understand and differentiate between the paragraph direction function and the
paragraph alignment function. Paragraph direction controls the order of multidirectional text inside
the paragraph. Paragraph alignment controls the placement of the whole line according to the left and
right boundaries.

Paragraph direction and alignment are independent. If your text is mainly Arabic or Hebrew, use a
“Right to Left” paragraph direction, otherwise, use the “Left to Right” option.

Left To Right hrabiqé Aalt peace S
Right to left Arabic S A2 peace |

You can access this option via:
- The formating tool bar (available via the menu View>Formatting Bar)
- The Inspector>Appearance panel (available via the menu View>Inspector)
- The menu Format>Paragraph Direction

- The menu Format>Line Spacing>Other...
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Formating tool bar
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Menu Format>Line Spacing>Other...
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Character Direction

FileMaker automatically calculates the default character direction according to the language/script of
the character, the paragraph direction as well as the surrounding characters.

In a few cases, some characters may not be displayed in the right position. In order to force the
direction of the misplaced character, use the right-to-left or left-to-right character direction option
in the Text Format dialog box.

- Aright-to-left character belongs to a language/script which is read right-to-left (example: Arabic,
Hebrew, Persian).

- A left-to-right character belongs to a language/script which is read from left-to-right (example
English, French).

You can access this option via:
- The Inspector>Appearance panel (available via the menu View>Inspector), see page 2
- The menu Format>Conditional
- By right-clicking on a field

Select “Conditional Formatting” in the “Conditional Formatting” dialog box, click “Add” to define a
new condition. Click on button “More Formatting”.

e

Style
| Font: Aial -
o T Flain Highlight
Size: 12 - Bold T
TextColor:  H+ Italic Subscript
il Calor:  Dlw Strikeout Condense
Small Caps Extend
Char Direction: ~ Right to Left
o g g Underline

Default
Left to Right Word Underline
M| —

[[lcase: UPPERCASE
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Digits
FileMaker Pro and FileMaker Pro Advanced allow you to use different digits: roman and native.

For example:

4528967 toyAdny

0 1 2 3 4 5 6 7 8 9 Arabic digits
. \ ¥ r £ o | v A 4 Hindi digits
You can access this option via: l
- The Text Formatting toolbar (available from menu View>Formatting bar)

- The Inspector>Appearance panel (available via the menu View>Inspector), see page 3

- The menu Format>Line Spacing>Other...
Menu Format>Line Spacing>Other...

Note: The language option of the field should support the Arabic or Hindi digits, See Image how to

change this option
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as needed

Applies to text indexing, sorting, and default display font.
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Spelling Option

FileMaker Pro and FileMaker Pro Advanced also include the support of the “cocoAspell” tool (Mac OS
X interface for Aspell) from Mac OS 10.4 for Arabic, Hebrew, Thai, Farsi, Vietnamese, Czech, Slovak,
Hungarian, Polish, Romanian, Slovenian, Croatian, Turkish, Estonian, Lithuanian, Latvian, Serbian,
Bulgarian, Ukrainian, Greek, Russian.

To use cocoAspell:
- Install cocoAspell using its installer
- Download the language pack (ftp://ftp.gnu.org/gnu/aspell/dict) from the FTP site.
- Once the archive is decompressed, copy the files into /Library/Application Support/CocoaSpell.

- The last step is to launch the preference panel (using System Preferences) and in preference
“Spelling” you choose which language you want to activate and which to deactivate.

- Restart FileMaker to see the activated languages.

Layout of Middle Eastern Content

FileMaker Pro and FileMaker Pro Advanced come with special settings for laying out right-to-left
content.

Controls

Each control can have right-to-left attributes such as alighment & direction.
- Dropdown list
- Dropdown calendar
- Edit box
- Popup menu
- Check box
- Radio button
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You can access this option via:

- The menu Insert>Portal
- The Inspector>Data panel (available via the menu View>Inspector)

Portal setup

Show related records from: [ Arabic_Glyphs i

["1Sart portal records
"1 Filter portal records
"1 Allow deletion of portal records

[ Show vertical scroll bar

"] Reset scroll bar when exiting record

|[:] Use Right to Left Layout |

Format

Initial row: ’1_‘ Number of rows: @
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Data panel
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Dropdown list
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Mirror Layout

FileMaker Pro and FileMaker Pro Advanced come with a new feature that offers you a mirror image of
your layout. This feature converts your layout from left-to-right to right-to-left.
A new menu item is available in Arrange>Mirror Layout.

Scripts Tools  Window  He

Group Ctrl+R
Ungroup Ctrl + Shift+R
Lock Chrl +AE+L
Unlock Chrl + 8t +Shift+L
Bring to Front Crl+48t+]
Ering Forward Ctrl +Shift+[
Send to Back Chrl +40t+]
Send Backward Ctrl +5hift+]
Rotate Ctrl + Al +R
Mirror Layout

Align »
Distribute »
Resize To »
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Find an example of this feature in the template below: before and after applying the Mirror Layout.

<<Event>>

Event Title Tasks Guests Agenda

Event

Task Assignee Due Dal:%

‘\:Z::Z B CoTash s @2 :nAsslgm.e.e..l..Mw e Daee) ... o) &
Date
Rate
Description
Rescription, Tasks [1..4+ Sorf]

Address {4 AddTask |l Print Task List
Addre

City State
Gty @] st
Eostal Code Country 5 Cecontriputor L maTcH FIELDE) 8. Emal
Pastal Code & county Role

Phone Email
Phone ] Emai

Contributor / Role Email

GetMapSieeAuto ("Map™; 12 ;
Events:Address ; Events: City ;
Events:State ; Events:Postal Code
Events:Country )

= Add Contributor & Print Contributor List

<<Event>>

=
Evernt Title

Rate

Description
Tasks[1.4+ Sor]

2. Description
? | adoress

+ AddTask B Print Task List

Addre

Phone Emall Contributor / Role Stale

=Contriputor | MATCH FIELDE) . Emall 2)(:Phane Q) o
Rale.

City

Postal Code
Pastal.Gods

GetMapSzeAuto ("Map™ ;12
Events:Address ; Events:City ;
Events:State ; Events:Postal Code ;
Events:-Country )

Print Contributor Lid Add Contributose
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Sorting - Search/Find

FileMaker Pro and FileMaker Pro Advanced come with extra languages for the sorting and search/find
attributes which allow you to sort, search and find Middle Eastern and Indian text.

Find the list of available languages in FileMaker Pro and FileMaker Pro Advanced below:
- For the Middle East : Arabic, Hebrew and other languages such as Farsi
Note: for better results, search your data without diacritics.

- For India : Hindi, Marathi, Bengali, Panjabi, Gujarati, Tamil, Telugu, Kannada and Malayalam

- For Asia : Thai, Viethamese
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To define the default sort language for indexing and sorting text, you simply open the “Options for
Field” box and click the appropriate options:

Options for Field “Venue Romanian !
: Slovenian

: Croatian
Auto-Enter | Validation
| | | T
Global Storage E’ri(::::ir;n
A field that uzes glo Latvian y one value that is
shared across all re Serbian (Latin) alsobe used az a
temporarystorage . |scTipts).
Bulgarian
Use global stora Flusgsian ds)
Ukrainian
Repeating Greek
Greel (Mixed)
Maximum number o
Arabic =
Farsi
Indexing Hebrew
Indexing improves | pindi ations like finds
and supports funct Marathi and field
value unigueness a Bengali size and time
spent indexing. Panjabi
o Gujarati
Indexing: () Mon Tamil @ Al
aut; Telugu as needed
Kannada -
Default language: | French E

Applies to text indexing, sorting, and default display font.

| oK || Cancel
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You can also select another language each time you sort data:

Slovak
Hungarian
Polish

Cumert Layout ("Evert Details) - g"’"a”ﬁa”
jovenian

Address o Clear Al ?";?—':1”
u

»Move » Estonian

Country ——  Lithuanian
Date Latvian
Serbian (Latin)

Description
Email Bulgarian
Russian

Ukrainian

Greek

Greek (Mixed)

h. ©) Descending order

Li ) Custom order based on value list -"_’ti'::
arsi

Hebrew

[~| Reorder based on summary field Hindi
[¥] Override field's language for sort French

[¥] Keep records in sorted order [ unsort |[ sot | [ cancel
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FileMaker WebDirect

FileMaker Pro et FileMaker Pro Advanced come with special settings for publishing databases on the
web.

You can share your database with users in a web browser, allowing them to find, browse, and modify

data with an English, Arabic, Hebrew interface as well as some other languages.

MNew Databasze...

Mew From Starter Solution...

Open... Ctrl+0
Open Remeote... Ctrl+Shift+ O
Open Recent L
Open Favorite L2
Cloze Ctrl+W

Manage L3

File Options... Share with FileMaker Clients...
Change Password... Enable CDBC/IDBC...
Configure for FileMaker WebDirect...

Print Setup...
Print... Ctrl+P

Import Records 4
Export Records...

Si
5
5 Configure the security and visibility of a file to be viewed in FileMaker WebDirect. This file must be hosted by
R
Ey

~ FileMaker Server.
o ‘ Currently open files | FileMaker WebDirect access to file ‘
. | Assets. i
File: Assets
@ Al users
() Specify users by privilege set | Speafy.. |
) No users
Don't display on Fi WebDirect h

(o [ concel |
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FileMaker templates seen in a web browser

¢« > C L@]_?2.16.0.99/fmi/iwp/cgi?fdb=Event%20Management&floadframes

@ Cette page est en Voulez-vous la traduire 7

New Event
Event Title
New Event
Venue
Date
jeudi 29 mars 2012
Description
A ddress
City
Postal Code — —
= = |
Untitled s Py
Title
lUnI:\tled ‘
Location ™
o Locaion ‘ L)
Date )
onetn 700
Start Time End Time
| []] [-]
| []] [+]
Fielated Mestings
1
= Untitled 29/03/12 -
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Diacritics and Ligatures
FileMaker Pro et FileMaker Pro Advanced come with special settings to preserve ligatures and diacrit-

ics.

When exporting and saving databases in pdf format the diacritics will be properly placed over the
consonants, both horizontally and vertically. The ligatures will be also correctly rendered.

See the example below:

File Edit View Insert Format Records Scripts Tools Window Help
-.]L

o
I#

Q-

Records Show All | Mew Record Delete Record | Find Sort
‘=l [ rreview |
(Control panel
O Colors ®Fruits O Vegetables O Faun O Nature
i &l
o
l Pineapple UJJUU‘
.‘ Strawbery :d Jl :)3
N s 2
a3 Tangerine ’9 \ ”‘%
e 0y
A 5
S s
SRy . 2
Raspb N
=, e &
- Fig =
“ o,
e P
¥4 > A

Note: for better results, search your data without diacritics.
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